
Quick Start

KoolMoves takes an approach to 
Flash™ movie creation that is in 
tune with the animation process, 
because it was designed by a 
professional animator. It is a mature 
animation package with ease of use 
and power as guiding principles. To 
make animations in KoolMoves all 
the user has to do is draw or import 
shapes or images and then 
reposition, reshape, and recolor the 
animation objects in adjacent key 
frames to achieve the look you want. 
KoolMoves automatically morphs 
shapes in between each of the shapes 
you create to achieve smooth 
animated motion. It's like putting 

together a cartoon strip. Each frame contains text, images, shapes, sounds, and 
actions. For character animation, one frame would have the characters in one pose and 
in the next frame in another pose.

The help is written primarily for the advanced/cartooning user interfaces. There is 
extensive context help on major screens. Look for usually in the upper left corner 
of a screen.

Skill Level Interfaces

In the interest of presenting to the user the easiest user 
interface for his skill level, KoolMoves has six user interfaces 
styles. The user can select which user interface he wants to 
use from the right of the top toolbar and also in File > 
Preferences > View. In Koolmoves 8.0, a new user interface 
for mobile device users was introduced which provides Html5 
export capability. In Koolmoves 9.1, another user interface 
for mobile device users that avoids the complexity of frame-
based animation and provides an integration with jQuery 
Mobile pages and widgets was introduced. A separate 
program called KoolShow features just the Html5 export part of KoolMoves.

The following table identifies the mapping between functionality and the six interface 
styles.

 Wiza
rds

Ba
sic

Advan
ced

Cartoo
ning

Html5 with
keyframes

Html5 with jQuery
Mobile widgets

Frame-based 
animation x x x x x  
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Page-based      x

Flash export x x x x   

Html5 export     x x

AVI, GIF 
export   x x   

Mobile app 
export   x x x x

Slide shows x  x x x x

Effects x x x x x x

SWF Flash 
Movie import  x x x   

Full set of 
drawing tools   x x x x

Shape point 
manipulation   x x x x

Dynamic text   x x x x

Masking   x x x x

Action 
scripting   x x   

Components   x x  x

FLV Flash 
Video import   x x   

Variable line 
width    x   

Non-linear 
morphing    x   

Bones    x   

Basic Skill Level Toolbars

Shown below are the toolbars for the Basic skill level (Flash export) with icon 
explanations.

The top toolbar:
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The basic tools toolbar:

The bottom frame navigation toolbar:

Advanced Skill Level Toolbar

Shown below is the Tools toolbar for the Advanced skill level with icon explanations. 
There are several toolbar options (File > Preferences - Toolbars tabbed page): single 
or double column, 24x24 pixel or 16x16 pixel icons.



Some of the toolbar icons have submenu choices. Click on the small triangle on the 
toolbar icon or click on the toolbar and hold for a second to get the choices. In File > 
Preferences - Toolbars tabbed page, chose between submenu popup or submenu 
drawer.

Most Important Tools

The following are the most important tools (displayed for the Advanced and 
Cartooning skill levels).

  1) A series of 
three tools, 
Shape 
Properties 
(shown here), 
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Score/Timeline, and Movie Overview are located on the top toolbar. These allow you 
to view and edit animation objects and their properties.

  2) Copy the current 
frame to create the 
next frame. One of 
the fundamental 

tasks of animation is copying the current frame as a starting point for creating the next 
frame. KoolMoves supports a fully WYSIWYG editing environment. The 
appearances of the shapes in each key frame are what you see in the Flash™ player 
(except for action script-based effects and components and jQuery Mobile widgets). 
To repeat this important concept, the process of creating an animation involves 1) 
copying the current key frame to make the starting canvas for the next key frame, 2) 
making changes to the shapes in the new key frame, and so on.

  3) Press the 
yellow VCR-
like play button 
to get a menu of 
the ways to play 
the animation. 
To export your 
animation as a 
Flash™ movie, 
just select File > 
Export Movie to 
create a Flash 
.swf file, a Flash 
.swf file with 
accompanying 
HTML, or to 
add a Flash animation to an existing web page. It is highly recommended that you 
read the help section on adding an animation to your web page.

Tutorials and More Help Topics

You can view examples created with KoolMoves by going to the Examples folder, in 
most cases located at C:\Program Files\Koolmoves\Examples. 

There are a number of Help aids under the Help menu bar -- Interactive KoolMoves 
Tutorials, FAQ, Simple Task Assistant.

Following this introduction, a number of topics are provided to guide you through the 
tasks associated with creating quality animations in KoolMoves and exporting them to 
the web.

The tutorials on our support page at www.koolmoves.com/support.html provide a 
basic understanding of the software and address specific needs. For tough questions, 
you can tap into the expertise of many people at once on our forum at 
www.flashkit.com/board/forumdisplay.php?forumid=24. The forum is also a great 
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place to share ideas, get feedback, and find out the latest news about KoolMoves, 
Flash and related topics.

Use Help > Update Software to obtain the lastest version.

Continue
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On-line Tutorials

www.koolmoves.com/support.html has a series of on-line tutorials. Users of the 
software can contribute tutorials.

koolexchange.com has many examples.

necromanthus.com/main.html has many action script examples.

www.waterlijn.info/km has many action script examples.

www.flashkit.com/tutorials/index.shtml has a wealth of tutorials on Flash techniques.

Continue
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Data Views

There are five important views of the data. Object properties, score/timeline, movie 
overview, list of objects in the current key frame, and list of all key frames. 
Properties, Score, and Movie Overview are next to each other on the top toolbar and 
can also be found under Views menu bar.

1) Almost all 
object 
properties are 
accessible from 
the properties 
window. It is 
the most 
important of 
the data views 
and the popups. 
Properties are 
accessible from 
the top toolbar, 
by double-
clicking on the 
object, by right-
clicking and 
selecting Properties, and by navigating through the Movie Overview.

2) A powerful view of the animation is obtained through the Score/Timeline window. 
The Score window floats over your workspace and can be positioned anywhere on 
your screen. It has four tabbed views -- Score, Effects, Actions and Sounds, and 
Storyboard. The Score view shows the shape population of each key frame and 
provides functionality for editing frames and objects. The Score view is equivalent to 
the timeline view in other Flash tools. An Effects view obtained by pressing the 
Effects tab provides an environment for viewing and manipulating effects. The 
Actions and Sounds view shows frame actions and sounds. The Storyboard view 
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shows the animation frames as thumbnails.

3) The Movie Overview 
provides a detailed hierarchical 
listing of all frames, objects in 
frames, actions and sounds, 
buttons and movie clips. It can 
be accessed from Views menu 
bar and from the top toolbar.

4) The List of Objects window which can be 
positioned anywhere and resized by dragging 
the resizing marks in the lower right provides 
the ability to lock objects, view which objects 
are masks and which are masked, 
cut/copy/paste/delete objects, and reposition 
the depth of the objects. It can be accessed 
from Views menu bar. Groups are shown as a 
hierarchy in the shape tree. Objects in the 
editing space can be selected by clicking on 
their names. A name can be changed by 
selecting the name, clicking again to get a 
cursor and typing in a new name like you do in 
Windows Explorer.



5) The List of Frames can be used for 
navigating, renaming key frames, and frame 
editing (cut, copy, paste, and reversing the 
order of frames). It can be accessed from Views 
menu bar and from the top toolbar. To change 
the position of one or more frames in the movie 
or to cut/copy/paste frames, make your frame 
selections in the list of frames and use the 
editing commands on the right. Shift select to 
select multiple frames. Paste places the cut or 
copied frames before the currently selected 
frame. To rename a frame, select the item in the 
list and click again to get a cursor. Type in the 
name you want. The window can be resized by 
dragging the resizing marks in the lower right.

Continue
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Adding and Editing Text

By pressing the Text tool on the 
Tools toolbar, a dialog window 
appears which allows you to 
customize the text: font, font 
style, size, country script, and 
letter spacing. You type your text 
in the large edit box.

You can edit selected text objects by double-clicking on the text or right-clicking and 
selecting Properties. Scale, rotate, flip, and squish transformations will affect text. 
You cannot manipulate the points associated with a text object. If you desire to do 
that, convert the text to shapes with points (under Transforms).

You can also add dynamic text 
which allows input from users 
or which can be changed as the 
animation proceeds using action 
script. This is explained more 
on the dynamic text page.

Regular text is heavily anti-aliased in the Flash player and is blurry at small type size. 
This problem cannot be controlled by KoolMoves. FFF Compact is a good font for 
small type. Dynamic text is lightly anti-aliased and is rendered exactly like text in 
HTML pages.

If you are having difficulty entering foreign characters, use the Alt key and a number 
in the numeric pad to the right of the standard keyboard. Don't forget to check that 
this pad is activated (NumLock key)! Press Alt, and, without releasing it, type the 
number corresponding to the character you want in the numeric pad.

Continue
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Effects

Using KoolMoves General Effects

You have about half a dozen powerful 
effects that can be applied to any shape, 
group of shapes, text, imported SWF 
movie, or movie clip. The effects are 
found under Effects menu bar, on the 
Effects tab of the Properties popup, the 
Effects view of the Score popup, and on 
the tools toolbar. First select a shape 
and then select the effect. Most of the 
effects occur over several key frames 
and you can specify how many key 
frames when you create the effect or at 
a later time by using Effects > Modify 
or by editing the effect in the object's 
Properties window. You can also 
combine effects in many cases; visit this 
online link koolmoves.com/nested-
effects.html.

A special kind of effect called motion script uses sophisticated Flash 6, 8, or 9 action 
scripting to create the effect. Each of these motion scripts is highly customizable. 
Motion scripts cannot be combined with other effects except as explained in this 
online tutorial koolmoves.com/nested-effects.html.

There are also 3D effects which have a similar user interface to the motion script 
effect. Each of these 3D effects is highly customizable. 3D effects cannot be 
combined with other effects.

Another special kind of effect called CSS3 animation effect uses CSS3 to create the 
effect. These effects are only available with Html5 export. Each of these effects is 
only slightly customizable. CSS3 animation effects cannot be combined with other 
effects.

The advantage of the regular built in effects like fade in and zoom in is that they can 
be applied to any object and they preserve any frame-by-frame user imposed color, 
shape, and position changes. The advantage of the action script-based effects is that 
they are more unique and are highly parameterized.

Shapes with a motion script effect are displayed in the editing screen with a 
surrounding blue dashed box. Other effects are displayed with a green dashed box.
There are YouTube tutorials at koolmoves.com/support.html.
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Add Flash Animation to Web Page

To run a Flash animation from your web page involves: (1) creating a swf file with 
KoolMoves and (2) adding javascript to your web page which references the swf file. 
KoolMoves will create this code for you. You upload your .swf and .htm/.html files 
and a special .js (javascript) file, swfobject.js or AC_RunActiveContent.js. This is 
analogous to creating an image in an image editing tool and adding code to your web 
page to display this image. The AC_RunActiveContent.js approach seems to be more 
robust but it has the disadvantage that is it more than three times as long. We found 
that the swfobject.js approach can result in an improperly displayed swf in certain 3D 
animations. If the name of the swf file starts with a number and you use the 
swfobject.js approach, change the swf file name so it doesn't start with a number.

Look under File > Export/Publish Movie for a number of different approaches to 
creating swf files and adding the necessary code to your web page. 

Users of FrontPage, see Using KoolMoves with FrontPage.

Users of CoolPage, see Using KoolMoves with CoolPage.

Users of NetObjects Fusion, see Using KoolMoves with NetObjects Fusion.

The name of the .swf file in the HTML file must be the same as the name of the .swf 
file on the server. It is best not to include spaces in the name.

Both the .html and .swf files are next sent to your web site by ftp. When you ftp the 
.swf file to your web site, make sure you send it as a binary file. The .html or .htm file 
must be sent as ascii. The better ftp programs like FtpVoyager do this automatically.

If you are having trouble getting the animation to play on the internet, these steps are 
recommended:

   1. If you double-click on the .html file generated by KoolMoves on your local disk, 
does the animation play in your default web browser. If it does, the .html and .swf 
files are OK. If it doesn't, your browser may not have Adobe's Flash player. Go to 
adobe.com with all your browsers and download the player (each browser may 
require a different download).

   2. Upload the KoolMoves generated .html (as ascii) and .swf (as binary) files to 
your web site. Does the animation play on your web site if you go to the KoolMoves 
generated web page? If not, there is a problem in how you sent the files to your web 
site. File > Export Movie > Diagnose Server Problems is a small expert system for 
diagnosing these types of problems.

It is possible to detect if the user is using an Apple product like iPad or iPhone which 
won't play Flash. There are a couple of tricks for redirecting to a non-Flash web site:
scottrockers.com/blog/resources/simple-code-tricks/how-to-detect-ipad-and-redirect-
to-ipad-version-website
davidwalsh.name/detect-ipad
css-tricks.com/snippets/htaccess/ipad-detection/.
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See Add to Web Page Details for more detailed information.
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Add Hmtl5 Animation to Web Page

Selecting either Html5 with Keyframe Animation or Html5 with jQuery Mobile 
Pages/Widgets interface provides Html5 export whereas the other interfaces 
exclusively export as Flash. Both methods for exporting as Html5 support canvas, 
CSS3 and Html5 effects, images, and video.

Html5 with Keyframe Animation export is analogous to Flash export in that both are 
frame-based animation. Morphing and frame-based effects are supported. Html5 with 
jQuery Mobile Pages/Widgets export is fundamentally different in that there are no 
key frames and the animation is composed of pages without any page-to-page 
morphing. The page metaphor should make the design process easier, because it 
reflects how the user views web pages. The simplier design is primarily intended for 
mobile web browsers. The widgets (button, checkbox, radiobox, listview, header, 
footer, navbar, textinput) are customizable with a classy look. For more information 
see api.jquerymobile.com/category/widgets/. Using the native IE browser for 
previewing the widgets can show misleading size and placement. For best rendering, 
select default browser in File > Preferences > Play. Opera browser also suffers from 
some placement and size rendering issues. If default zoom other than one is set in the 
browser, size and placement of objects on the canvas will be affected.

By exporting as Html5, it is possible using PhoneGap, a free and open source 
framework, to create app-store ready mobile apps for all platforms. PhoneGap Build 
service compiles the apps in the cloud. For more information, see phonegap.com. 

The new canvas tag in Html5 allows export of animation. To test a browser's support 
of Html5, go to http://html5test.com/.

Only a subset of KoolMoves functionality is available for Html5 export. The user 
interface restricts functionality to what is available but there may be other 
functionality appearing in the interface which is ignored on export. If a .fun file is 
opened in the Html5 gui that was created with the Flash gui, most likely some fraction 
of the movie will not be exported as Html5. Flash at this time and maybe forever 
provides considerably more capability than Html5.

Use File > Export/Publish Movie to generate the hmtl code with file dependencies or 
to generate a complete web page. Be sure that you copy the javascript files referenced 
at the top of the web page -- Easeljs.min.js, Tweenjs.min.js, Movieclip.min.js, and 
Kooljs.min.js (or Core.js, Ease.js, and ImageEffect.js) -- to the server with the html 
page. The files can be found in KoolMoves \ Javascripts for Html \ CreateJS or 
KoolMoves \ Javascripts for Html folder. If Html5 with jQuery Mobile Pages/Widgets 
is chosen, there are additional javascript and css files.

It is possible to detect if the user is using an Apple product like iPad or iPhone which 
won't play Flash. There are a couple of tricks for redirecting to a non-Flash web site:
scottrockers.com/blog/resources/simple-code-tricks/how-to-detect-ipad-and-redirect-
to-ipad-version-website
davidwalsh.name/detect-ipad
css-tricks.com/snippets/htaccess/ipad-detection/.
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Drawing

There is a rich selection of drawing tools in KoolMoves: freehand, primitive shapes 
(ellipse, circle, rectangle and square), and shapes/lines drawn point-by-point.

Toolbar buttons with arrows in the lower right have sub-selections. You can view the 
sub-selections by pressing the toolbar button until the sub-selections appear or by 
pressing on the triangular arrow in the lower right of the toolbar button. The selection 
indicated on the toolbar button is the active selection.

The freehand drawing tool allows you to draw like 
you would using a pencil. The first and last points 
are automatically connected when you release the 
mouse. If you don't want them to be connected, after 
the shape is drawn change the Closed property of 
the shape. The points generated by freehand 

drawing are curve fit to achieve a modest number of points. You can add or delete 
points later if needed.

The tools for drawing primitive shapes make it easy 
for you to draw circles, squares, rectangles, and 
ellipses. You click the left mouse button at one 
corner of the shape you want to draw and drag the 
mouse to the opposing corner of the shape. Release 
the mouse and the shape is drawn.

At the bottom of the Tools toolbar (double column 
only) are three options: fill color, border or line color, and border or line thickness. 
These options are present with any of the drawing tools and once set will remain until 
changed. Changing these options does not affect existing shapes already drawn.

Shapes drawn point-by-point allow you to control the 
placement and number of points. You click the left 
button to define each point and continue until you 
have completed the shape.

To add a curve while drawing point-by-point, 
drag the mouse in the direction of the intended 
curve after clicking to create a point without 
releasing the mouse.

To finish, double-click or press Esc. The first and last points are automatically 
connected. If you don't want them to be connected, change the Closed property of the 
shape.

Shapes and lines with curves are defined by on-shape points 
and off-shape points (indicated by dashed circles). 
Technically, curves are quadratic bezier splines. You can 
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change the shape of the curve by moving selected points, on-shape and off-shape, by 
dragging or using the arrow keys.

You can 
control the 
appearance of a 
shape through 
its:

1) Fill
2) Border 
thickness
3) Border/line 
color
4) Last border 
segment

Lines are 
shapes that are 
not filled and 
have a border with the last segment not drawn. Lines can be changed to closed shapes 
by setting the Filled and Closed properties to yes. Text does not have a border.

Continue
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Selection

Object and point selection tools are located 
on the top part of the Tools toolbar. These 
tools are used a lot. In addition to 
providing selection capability, they also 
allow you to move objects on the canvas 
and points defining objects. You can move 
previously selected objects or points by 
dragging the mouse with the left mouse 
button depressed.

One way to select an object is by clicking on the 
object when the object selection tool is active. If 
you click on an object with the shift key 
depressed, you will add to any previous selections.

Another way to select one or more objects is 
by dragging the mouse across the objects 
totally enclosing them. If you drag the mouse 
with the shift key depressed, you will add to 
any previous selections.

A third way to select one or more objects is by 
invoking the List of Objects (under Objects 
menu bar) and selecting from that list. Objects 
are automatically named as they are created but 
you can change the name by editing the name 
in the list.



A point can be selected by clicking on the point 
when the point selection tool is active. The 
selection area associated with a point can be set 
under Points. If you click on a point with the shift 
key depressed, you will add to any previous 
selections.

Another way to select one or more points is by 
dragging the mouse across the points totally 
enclosing them. The points can be associated 
with different objects. If you drag the mouse with 
the shift key depressed, you will add to any 
previous selections.

It is important to appreciate that point and object selection is very general. You can 
select multiple objects or multiple points. The multiple points can even be associated 
with different objects. Selected objects and points can be moved by dragging the 
mouse or by pressing the arrow keys.

Selection can also apply over many frames. There are four 
degrees of object and point selection: (1) current frame only (the 
most common), (2) all frames in the movie, (3) all frames from 
the current frame to the first frame, and (4) all frames from the 
current frame to the last frame.

The ability to select over multiple frames is very powerful. For 
example, if you change the color of a object in the current frame 
and the object has been selected over multiple frames, the color 
change will be applied to each of the selections. To prevent 
inadvertent sweeping changes, you are first asked if you want to 
change the other frames. The ability to change selected objects 
and points over multiple frames based on what you are changing 

in the current frame applies to most of the functions in KoolMoves -- transformations, 
shape fills, translation, etc.

Sometimes you want to exclude some points from possible selection. An easy way to 
do this is to select the shape associated with the points you want to select and then 
select the point selection tool. Only the points associated with the previously selected 
shape will be visible. To hide objects or points you can use Objects > Hide Selection 
or Points > Hide Selection. Selecting Objects > Show Objects or Points > Show 
Objects brings the objects or points back. Objects > Invert or Points >Invert inverts 
the current object or point selection.

Continue
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Coloring

Shapes 
and text 
can be 
filled 
with a 
solid 
color (with or without transparency), a color gradient, or a tiled image. Access to the 
Shape Fill dialog is through the shape properties dialog box and the Shape Fill tool on 
the left toolbar.

To fill with a solid color:

Select Solid 
Color at the top 
of the dialog. 
You can (1) 
enter red, 
green, and blue 
(all 0 to 255 in 
range) and a 
transparency 
value (0 to 100 
in range), (2) 
select with 
your mouse 
from the color 
wheel (partially 
shown), (3) use 
red, green, 
blue, hue, 
saturation, and 
lightness 
sliders (press 
the button on 
the left under 
the 
transparency value), or (4) use an eyedropper (press the button on the right under the 
transparency value) to select a color from another shape on the drawing canvas. To 
view the shape fill before committing, press Preview. On OK, the shape fill is applied 
to all selected shapes.

To fill with a color gradient:

Select Color Gradient at the top of the dialog box. A gradient fill is comprised of up to 
eight color pointers. The color associated with the selected color pointer is shown 
underneath the gradient definition bar. The color of the selected color pointer (it is the 
color pointer which is depressed) can be changed by (1) entering red, green, and blue 
values (all 0 to 255 in range) and a transparency value (0 to 100 in range), (2) 
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selecting with your mouse from the color wheel (partially shown), (3) adjusting the 
red, green, blue, hue, saturation, and lightness sliders. The color gradient can be either 
linear or radial. Color pointers can be dragged to the left or right along the gradient 
definition bar to change the gradient effect. Only a shape with points can be filled 
with gradient color. To fill text with gradient color break it apart into a shape with 
points (Transforms/Break Apart Text).

A color 
pointer can 
be added by 
pressing the 
small button 
with the 
plus sign. 
The mouse 
cursor turns 
into a color 
pointer with 
a + in the 
middle. 

Click at a position on the gradient definition bar. Then change the color of this color 
pointer. A color pointer can be deleted by pressing the small button with the minus 
sign and the selected color pointer is deleted.

The rotational 
orientation 
and position 
of the gradient 
fill can be 
adjusted with 
Rotate/Shift 
Gradient Fill 
under 
Transforms 
menu bar and 
at the bottom 
of the gradient 
fill window. Using the two other gradient transform tools, moving the center of the 
gradient fill to the right shifts the gradient to the right and moving the cursor around 
the center rotates the gradient.

To fill with an image:



Select Image at the top of the dialog box. Use the Browse "..." button to locate your 
image file. Bmp, jpeg, tiff, pcx, and png file formats can be imported. Transparency in 
png files is ignored at this time. If you use the same image with the same filename 
multiple times throughout the movie, KoolMoves is smart enough to store the image 
only once in the exported Flash™ movie. If the image is larger than the shape, only 
the upper left portion of image will fill the shape. If the image is smaller than the 
shape in any dimension, the image will tile to fill the shape. Only a shape with points 
can be filled with a image. The transparency of the image can be adjusted with a 
slider. 

You can preview the fill by pressing Preview. On pressing OK, the fill, either color, 
gradient, or image, will be applied to all currently selected shapes and, if the fill is 
color, to all selected text.

Continue
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Object Properties

You can 
control the 
appearance of a 
shape with 
points through 
its:

1) Fill
2) Border 
thickness
3) Line color
4) Last border 
segment

To make the 
interior of the 
shape 
transparent, 
select Filled 
and choose 
No.

This shows a 
shape that is not 
filled.

To change the 
border thickness 
around the shape 
or the thickness of 
a line, select Line 
Width.



This shows a 
shape with no 
border (i.e., line 
width equal to 0).

To set whether 
the last border 
segment of the 
shape is drawn or 
not, select 
Closed.

This shows a 
shape with the 
last segment not 
drawn. When the 
shape is also not 
filled, we have a 
line.

The property dialog 
for text looks 
different because text 
has different 
properties than 
shapes with points. 
The color of text can 
be changed by 
clicking on the Color 
property. A dialog 
that lets you set color 
will appear. The text, 
font, font size can be 
edited by clicking on 
the Type property. A 
dialog will appear in 
which you can edit 
the text.

Assigning button properties and making a non-text shape into a symbol are explained 
in the next section.
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Frame Events

Sounds and actions can be assigned to key frames. Select Views > Actions and 
Sounds, right-click on the canvas and select Edit Frame Actions and Sounds, or use 
the Actions and Sounds tabbed page of the Score View. 

With this dialog, you can enter sounds and actions associated with frames of the 
animation. This is very simple. Select a frame by clicking on its name. Click on the ... 
button in the Sound group box and browse your file directory to select a MP3 or wav 
sound file. When the animation plays that frame in your web browser the sound will 
also play. There are also a wide range of actions that can be activated when the frame 
is played. Click on the Add Action + button in the Action group box. This dialog also 
provides a view of button actions and sounds. Because a button often appears in all or 
most of the movie, the button events are listed for only the first frame the button 
appears in.

Sounds (MP3 and .wav PCM formats) can be added to KoolMoves movies. There are 
about 68 individual wav formats. At this time, KoolMoves only supports PCM type. 
Press the folder button to select the file location of the sound. Press the sound icon to 
play the sound (MP3 sound is played in a web browser window using the Flash 
plugin). The trash can icon will delete the sound. The waveform icon will show the 
sound in an audio editor of your choice once the audio editor has been defined in File 
> Preferences.

If you use the same sound file multiple times throughout the movie, it will be 
referenced that many times in the Flash™ movie but only defined once.

Sound files tend to be huge which can make the exported swf file huge. To make 
sound small, take these steps: in a sound editing program convert from stereo to mono 
and to the smallest sample rate that gives you the quality you need. Shortening the 
sound track also helps.

Sounds can also be attached to button states (e.g. moving the mouse over a button or 
on pressing a button). See button sounds for more information.

Sounds do not play when running your animation in KoolMoves' internal player.

If a sound plays longer than the movie plays and if the movie loops, the sound from 
the first loop will continue playing during the second loop until the sound from the 
first loop finishes. The sound effect worsens as the movie continues to loop. To solve 
this problem, add Stop Sound action to the last frame.

If your sound file is sampled at a rate other than 5500, 11025, 22050, or 44100, the 
sound will play in the Flash player at a rate nearest to one of the four rates listed 
above.

The duration of a sound is indicated in the Actions and Sounds View window and in 
the Actions and Sounds page of the timeline by a sound icon followed by small 
squares. 
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It is important to note that a stop movie action in the first frame is often ignored by 
the Flash player. The solution is to create a dummy first frame.

For use on the web, the URL for the loaded movie can be an absolute or relative 
URL, but, for testing purposes, all the movies must be in the same directory without 
directory or disk drive specifications in their names. When testing a movie using Play 
in Browser, any HTML and SWF files, referenced by Get URL or Load Movie 
actions, MUST be in the same directory as the fun file for these button actions to 
access these files or set the directory for playing the movie in Preferences.

In order to daisey chain movies together using AS1 action script, you use Load 
Movie. Create a base movie that loads in the other media and then loops - make sure 
that you do not loop in the load movie action. Load your main movie into Level 2 and 
your background into Level 1. Run your movie to the end then use a Load Movie 
command into Level 2. This will load the new movie into that level. Then create 
aditional frames and loop back. Chaining movies together using AS3 action script is 
unfortunately a lot more complicated.

Load movie frame action loads a movie without closing the current movie. Unless 
you include in the loaded movie a shape under all other shapes that equals or exceeds 
the size of the movie frame and that is filled with an opaque color or a bitmap, you 
will see the first movie underneath the loaded movie. The size and speed of the movie 
are set by the movie at level 0.

None of the frame actions function in the KoolMoves internal player.

Continue
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Links and Buttons

A shape or text is made into a button by 1) selecting Objects > Convert to Button or 2) 
right-clicking then select "Convert to Button" or 3) pressing the Button icon (Convert 
to Button sub menu selection) on Tools toolbar or 4) selecting "Is a button" property 
in Properties popup. A button can serve as a link to another web page but it can be 
much more than that. You can design the button's appearance to change for different 
mouse events, and you can program actions like "go to another web page on release of 
the button" (called GetURL action).

A button can 
dynamically assume 
in the Flash player or 
on a web page 
different appearances, 
reflecting whether the 
mouse is away from 
the button, over the 
button (e.g., mouse-
over effects), or has 
pressed the button. You create and edit the three button states (Up, Over, Down) from 
the States button at the top of the properties popup (once the object has been 
converted into a button). Each state can have its own sound, shape color, etc. The 
actions for the button -- what the button does like cause the web page to change -- are 
added to the button object not any of the button states (Up, Over, Down). Because the 
interface is WYSIWYG (what you see is what you get), the button appears in the final 
animation for each frame the button appears in the editing environment. In other 
words, if the button is missing in a frame, it will be missing in the final animation in 
that frame.

If you press the States button in the button Properties window or right-click and select 
Edit Button States, you enter a button editing environment as shown here. In 
converting the original object into a button, the Up state is created from the original 
object. To create an Over state, press the Over button on the top toolbar. When you 
press the Over button (corresponding to mouse events roll over, roll out, drag over, 
and drag out) for the first time, a popup will appear asking you if you want to create 
the Over state from a previously drawn state or if you want to draw it from scratch. If 
you are only changing the color of the state, you would select copy the Up state and 
edit the color from the value corresponding to the Up state to the value you want to 
correspond to the over state. 
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In the Over state editing mode, you can change properties of the Over state and edit 
the shape corresponding to the Over state. A cross hair is shown to assistance in 
aligning the different button states.

By 
pressing 
on the 
actions 
property 
button in 
the 
Propertie
s 
window 
for the 
button, 
you can 
assign 
and edit 
the 
actions 
for the 
button which may be triggered by different mouse events. By pressing on the sounds 
property button, you can assign sounds for the Over and Down states.

The + button 
presents you 
with the 
possible 
button 
actions, most 
of them self-
explanatory. 
Each of these 
actions can 
respond to 
one or more 
mouse events.

Selecting Get URL, 
presents us with this 
popup. We can select 
which mouse events 
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activate the Get URL action. The URL for the action is filled in. The Over state of a 
button is activated for roll over, roll out, drag over, and drag out mouse events. The 
Down state of a button is activated for press, release, and release outside mouse 
events.

On pressing OK, the action is 
added to the list of actions 
associated with this button. 
Any action can be edited or 
viewed in more detail by 
double-clicking on it or by 
selecting it and then selecting 
the properties button (second 
from the left at the top of the 
Actions popup).

The actions for a button cannot vary from frame to frame. If you want a button's 
actions to change from one frame to the next, copy and paste the button in the same 
frame that contains an instance of the button and then cut and paste this button to the 
frame where you want the actions to be different.

Symbols

One of the principal methods for creating small Flash™ animations is by making as 
many shapes into symbols as possible. A symbol is a shape that is shared by other 
shapes (called instances of the symbol). If you move a point in one instance it will be 
moved in all instances throughout the movie (KoolMoves first asks you if you want to 
change all instances). If you change the gradient in one instance, all instances will be 
changed. And, so on. The exceptions to this are the interior color of the shape, shape 
position, scale and rotate transformations. These four only change the instance acted 
upon, not all instances. This is dictated by the Flash file format.

For simplicity, KoolMoves treats all text shapes as symbols.

If you have shapes that appear more than once in a single frame or in multiple frames, 
then it is advisable to make these shapes into symbols if you do not intend to move 
individual points from one frame to the next. In many cartooning situations, you 
would want to move points from one frame to the next to make a mouth move to 
simulate talking or to made a hand move to simulate waving, etc. so such shapes 
would not be good candidates for symbols. If the shape is stationary and undergoes no 
change throughout the movie, it is not necessary to make the shape into a symbol 
(KoolMoves will automatically handle this situation).

To make a shape into a 
symbol, select Yes for the 
Symbols property. This should 
be done immediately after 
creating the shape before a 
copy is made within a frame 
or a frame is copied. Notice 



that the points to the shape have a different appearance to indicate that these points 
are potentially shared with other shapes. The symbol instance is edited like any other 
shape. If the change affects other instances you will be warned.

Continue

mouseover.htm


Roll-Over Example

This 
basic 
tutorial 
will 
define the 
steps 
necessary 
to create a simple roll-over effect using text.The text is made into a button by 1) 
selecting Objects > Convert to Button or 2) right-clicking then select "Convert to 
Button" or 3) pressing the Button icon (Convert to Button sub menu selection) on 
Tools toolbar or 4) selecting "Is a Button option" in the text's Properties window.

If you press the States button in the button Properties window (which was added 
when the text was converted into a button) or right-click and select Edit Button States, 
you enter a button editing environment as shown here. In converting the original 
object into a button, the Up state is created from the original object. To create an Over 
state, press the Over button on the top toolbar. When you press the Over button 
(corresponding to mouse events roll over, roll out, drag over, and drag out) for the 
first time, a popup will appear asking you if you want to create the Over state from a 
previously drawn state or if you want to draw it from scratch. If you are only 
changing the color of the state, you would select copy the Up state and edit the color 
from the value corresponding to the Up state to the value you want to correspond to 
the over state. 

To make the button's over state different than the up state, the text 
color is changed.

To return to 
the main 
movie, press 

the Main Movie button.



When the movie is played and the mouse is away from the button we see the button's 
up state. When the mouse is over the text button, we see the button's over state.

Continue
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Masking

Masking is a very powerful technique. The following illustrates a simple animation 
example of letters being revealed from left to right using a gradient and a text mask.

We start with a circular shape, no border, that is filled 
with a gradient. On top of that we place a text shape. 
The text is the mask. Think of it as a cookie cutter. The 

mask cuts out what is underneath to the extent of its masking depth which in this case 
is 1. The fill or color of the mask is immaterial. The mask itself is invisible when the 
animation plays. In the editing environment, the mask is by default visible.

A shape is made into a mask in the property dialog. The depth of the masking effect is 
also assigned in the property dialog. Anything except buttons can be made into a 
mask.

In the first frame, the gradient filled shape is positioned 
to the left of the text. The frame is copied and the 
gradient filled shape is positioned to the right of the 

text. During animation, the gradient will sweep across the text revealing the letters.

To see the effect of the masking, press Ctrl+M. This is how the animation will 
look when this key frame is played. Repeating Ctrl+M removes the masking 
effect and the mask is made visible again.

The List of Objects window identifies masking 
shapes and shapes which are clipped by masks 
with two different icons (the donut represents 
the mask and the donut hole represents the 
object masked). The mask is always on top of 
the shapes which are clipped by the mask.

Continue
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Editing and Playing Frames

To make a movie grow in size, you typically copy your current frame to the end of the 
movie. In the new frame, you change positions of shapes, move shape points, change 
colors, add new shapes, etc. to develop the animation.

You can navigate between key frames by moving the frame slider or pressing first 
frame, previous frame, next frame, or last frame buttons on either side of the slider. 
The name of the current key frame is shown on the left.

You can display a list of all the key frames 
using Views > List of Key Frames. This list can 
be used for navigating, renaming key frames, 
and frame editing (cut, copy, paste, and 
reversing the order of frames). To change the 
position of one or more frames in the movie or 
to cut/copy/paste frames, make your frame 
selections in the list of frames and use the 
editing commands on the right. Shift select to 
select multiple frames. Paste places the cut or 
copied frames before the currently selected 
frame. To rename a frame, select the item in the 
list and click again to get a cursor. Type in the 
name you want. The window can be resized by 
dragging the resizing marks in the lower right.

The number in the combobox 
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is the number of tween frames between the current frame and the next. You generally 
want this number to be greater than zero so KoolMoves will generate smooth 
transitions (called morphing) between the key frames. Adding tween frames in most 
cases is cheaper than adding key frames in terms of the size of an exported Flash™ 
movie, particularly for shapes with many points. Adding tween frames also lets you 
control the speed of the movie at a specific frame -- the more tween frames, the 
slower the transition to the next key frame.

KoolMoves has 
an internal 
player which 
plays the movie 
in a loop. You 
can also single-
step through the 
movie. You can 
view the movie 
in your web 
browser as a 
Flash™ movie 
on a blank web 
page or in a 
stand-alone 
Flash™ player 

if you have one. You can download a free Flash player from Adobe.
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Reshaping

The heart of animation is movement. Movement is achieved by changing shapes from 
one frame to the next. Change can take many forms: moving a shape from one 
position to another, moving or transforming points associated with a shape, changing 
the color of the interior or border of the shape, adding or removing points from the 
shape. KoolMoves provides a number of tools to accomplish all these tasks without 
getting in the way of your creativity.

To move a shape or a group of shapes is simple. Select the shape or group of shapes 
with the object selection tool (arrow icon located at the top of the Tools toolbar) and 
drag the mouse. For fine precision movement, you can use the arrow keys. The 
combination of shift plus an arrow key produces a movement of 10 pixels. To move a 
point or a group of points is equally simple. Select the points with the point selection 
tool (arrow icon with a small square to the right located at the top of the Tools 
toolbar) and drag the mouse. For fine precision movement, you can use the arrow 
keys.

Shapes and lines with curves are defined by on-shape points 
and off-shape points (indicated by dashed circles). You can 
change the shape of the curve by moving the individual 
points.

To add a point to the 
boundary of a shape use the 
Add Point tool (whether the 
shape has a border or not or 
whether the fill is a color or a 
bitmap).

You get a cursor that indicates when you are allowed to add a 
point. It looks like this when you are not on a boundary line.

And it looks like this when you are on a boundary line.

Click the mouse and a point is added.

Without releasing the mouse, you can drag the point to a new 



position.

To delete a 
point on the 
boundary of a 
shape use the 
Delete Point 
tool.

You get a cursor that indicates when you are allowed to 
delete a point. It looks like this when you are not on a point.

And it looks like this when you are on a point.

Click the mouse and the point is deleted.

To change the boundary of a 
shape from a straight line to a 
curved line, use the Add 
Curve tool.

You get a cursor that indicates when you are allowed to add a 
curve. It looks like this when you are not on a straight boundary 
line.

And it looks like this when you are on a straight boundary line.

Click the mouse and a curve is added.



Without releasing the mouse, you can drag the curve point to a 
new position.

To scale, rotate, flip horizontally or vertically, slant, squish, or create perspective on 
one or more selected shapes or one or more selected points, use one of the transform 
tools. All of the tools present a set of handles that you can drag in different directions 
to achive the effect you want.The rotation tool lets you define the center of the 
rotation indicated by the small square plus cross mark. You drag this square to set the 
center of rotation. All the tools transform text except slant and perspective.

Squash is the effect used in animation to show the effect of gravity on an object. 
Stretch is the effect used to show the effect of movement against gravity. A good 
example would be a rubber ball bouncing. When the ball hits the ground, its shape 
changes from a circle to an ellipse and as it accelerates back into the air (bouncing) its 
form stretches slightly. Both squash and stretch can be created by using the squash 
tool in the effects tool section.

Continue
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Movie Clips

Movie clips are an advanced feature of KoolMoves. A movie clip is a movie within a 
movie with its own frames and timeline. Movie clips are important because the 
properties of movie clips can be dynamically changed via action scripts.

There are several ways to create a movie clip -- press the movie clip icon on the Tools 
toolbar or select Objects > Add Movie Clip or Convert to Movie Clip.

In converting ojects to a movie clip, the selection scope -- this frame only, all frames, 
etc. -- determines the composition of the movie clip. If you select a number of shapes 
in the current key frame and select all frames for the selection scope, all those shapes 
in whatever frames they appear will be converted into a movie clip.

A selected movie clip symbol is similar to a regular symbol except for the blue/gray 
shading in the corners. Double-clicking on a movie clip symbol produces its 
Properties window.To reveal the composition of the movie clip and enter its timeline, 
press the Frames button at the top of the Properties window or right-click and select 
Edit Movie Clip Frames.

Continue
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Bones

Bones can be attached to anything except symbol shapes. If you are currently drawing 
shapes as symbols, you should probably turn off this option in Preferences. Bones 
capability is only available in the Cartooning interface style. 

Bones is a feature that often comes with expensive character animation software. It 
provides the designer with the ability to attach a skeleton to a figure. Changes in the 
position of the limbs of the figure can be achieved efficiently by manipulating the 
skeleton. The nickname for this feature is often called bones. KoolMoves has a 
primitive bones system. 

To attach bones to this 
simple figure, indicate in 
the properties dialog for 
the shape that the figure 
has bones. Bones can be 
attached to a single shape 
or a shape group. To add 
or edit bones, press the 
Bones button at the top 
of the dialog.

Similar to editing button states, you are given an environment for editing bones 
against the faint image of the shape to which the bones are attached. The draw bones 
tool behaves identically to the line drawing tool in the main editing window.

You draw bones by dragging the mouse and clicking the 
mouse at each joint.
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Double-click to finish. When you release the mouse, all the 
joints are highlighted.

Other limbs are drawn in a similar fashion.

This is what is looks like when all the bones are added.

Certain joints you would like to be shared 
between different limbs. The way to do that is 
by using the join tool. Press the join tool and 
drag a box around the joints you would like to 
act as a single joint. Under the join tool is an 
unjoin tool.

When you are finished editing the bones, 
press the "Body Shape" button. This 
shows the figure with its newly added 
bones in the main drawing window. You 
can move joints in this window by 
selecting the select/move joints tool.



This illustrates selection and movement of a joint. There is 
much room for improvement in our implementation 
particulary regarding the dynamic interaction between the 
bones and body of the figure

You can view the primary and secondary joints the program uses in controlling each 
shape point by clicking on View > View Associated Joints and selecting a shape 
point. Some points only have a single joint controlling them.
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Shortcut Keys

File  
Ctrl+O Open
Ctrl+N New
Ctrl+S Save
  
Edit  
Ctrl+Z Undo
Ctrl+Y Redo
Ctrl+X Cut
Ctrl+C Copy
Del Delete
Ctrl+V Paste
Ctrl+W Paste objects complete copy
  
Views  
Shift+F3 Score/timeline
Alt+F3 Movie overview
Ctrl+E Actions and sounds overview
F11 Symbol library
F9 List of objects
Ctrl+K List of key frames
Shift+F2 List of scenes
  
Objects  
Space Select/move
P Properties
F Color/image fill
Ctrl+H Hide/unhide objects
Ctrl+I Invert selection
Ctrl+L Last selection
Ctrl+F11 Add to symbol library
Ctrl+Up Bring forward
Ctrl+Down Send backward
Ctrl+Shift+Up Bring to front
Ctrl+Shift+DownSend to back
Alt+Up Bring forward selection
Alt+Down Send backward selection
Ctrl+Shift+L Align left
Ctrl+Shift+R Align right
Ctrl+Shift+T Align tops
Ctrl+Shift+B Align bottoms
Ctrl+Shift+H Align on horizontal centers
Ctrl+Shift+V Align on vertical centers
Ctrl+G Group
Ctrl+Alt+G Add to group
Ctrl+Shift+G Ungroup
Ctrl+A Select all
Ctrl+Shift+A Unselect all



  
Points  
Del Delete
  
Transforms  
N Numeric
S Scale
R Rotate
Ctrl+Alt+P Perspective
Ctrl+Alt+S Slant
Ctrl+Alt+Q Squish
Ctrl+Alt+C Center
Ctrl+Alt+H Flip horizontally
Ctrl+Alt+V Flip vertically
  
Frames  
K Add copy of frame
Ctrl+End Add copy of frame to end
Ctrl+B Add blank frame
A Edit action script
F8 Edit actions/sounds
  
Movie  
Ctrl+D Movie dependencies
  
Play  
Ctrl+Space Play in web browser
Ctrl+Alt+Enter Play in stand-alone player
> Single step forward
< Single step backward
  
Options  
+ Zoom in
- Zoom out
F4 No zoom
H Pan
Ctrl+M Show all masking
  
Help  
F1 Help
  
Esc Stop internal player or finish point by point drawing
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How To Tips

1. To select a shape or points under another shape:

    Select the shape on top and then press CTRL H to hide the shape thus revealing 
what is underneath. Press CTRL H again to undo the hide.

2. To change the fill of a shape everywhere:

    Select the shape with the selection scope set to All Frames. Whatever you do to the 
shape is now reflected everywhere. You are prompted first before global changes are 
implemented.

3. To name a shape, select a shape by name, or select a hard to get at shape:

    Use the Shape List tool. Using this tool, you can select individual shapes or 
multiple shapes with CTRL and SHIFT select.

4. To combine KoolMoves, Swish, and Flash™ authored movies:

    Use the frame or button load movie action to load movies created by other tools or 
import the movies as objects.

5. To create a tiled background:

    Create a rectangle slightly larger than the movie frame in the first frame and send it 
to the back. Use the fill tool to fill the rectangle with your image. It will tile. Copy the 
rectangle, go to the second frame and use Edit > Paste to end of movie.

6. To overcome Flash™ movie size limitation:

    The Flash™ player sets a limit on the size of the main swf. If you are including a 
large sound file, make it a separate swf and use load movie action to load it into the 
main movie. In this way you can effectively double the allowed size of the movie. 
This approach works in general for creating large animations. Moreover, breaking the 
movie into pieces results in faster internet loading.

7. To make an entire swf a link on a web page:

    Put a shape the size of the movie frame filled with the background color in all 
frames, send it to the bottom and make it a button OR put a shape the size of the 
movie frame filled with a totally transparent color in all frames and make it a button.

8. To reposition the movie frame in the main editing window:

    Use Options > Reposition Movie Frame.
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lockshapes.htm
screensaver.htm
exe.htm
masking.htm
avi.htm
dropshadow.htm
swfobject.htm
dependencies.htm
code.htm
linevariation.htm
projector.htm
exceedbuffer.htm
link.htm
transbackground.htm
swftoobig.htm
mpg.htm
blackborder.htm
powerpoint.htm
thickness.htm
email.htm
databases.htm
importtif.htm
importjpg.htm
importpng.htm
importpcx.htm
midi.htm
svg.htm


Known Issues

If other large applications are running while KoolMoves is running, KoolMoves may 
crash. This is due to a lack of system or graphic resources.
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